Skip to main content

Canva AI · 74d ago

Users may experience errors uploading media

Resolved

Timeline

Started: Jul 2, 2026, 9:10 AM UTC

Last update: Jul 2, 2026, 11:00 AM UTC

Resolved: Jul 2, 2026, 11:00 AM UTC

Affected: 89nxpr1qlgrr

Canva AI's official report →

Updates

  • resolved

    This incident is now resolved. Thank you for your patience and understanding.

    Jul 2, 2026, 11:00 AM UTC

  • investigating

    We are continuing to investigate this issue.

    Jul 2, 2026, 9:12 AM UTC

  • investigating

    Users may experience errors uploading media to their Canva design

    Jul 2, 2026, 9:10 AM UTC

← All outage history