Canva AI · 64d ago
Some users may have issues downloading video designs
ResolvedTimeline
Started: Jul 12, 2026, 8:38 AM UTC
Last update: Jul 12, 2026, 5:29 PM UTC
Resolved: Jul 12, 2026, 5:29 PM UTC
Affected: mxj4mxnt79s9
Updates
resolved
This incident is now resolved. Thank you for your patience and understanding.
Jul 12, 2026, 5:29 PM UTC
identified
Some users may experience issues downloading video designs. Our teams are currently working to resolve the issue.
Jul 12, 2026, 8:38 AM UTC