Skip to main content

Canva AI · 62d ago

Some users may have issues using Canva

Resolved

Timeline

Started: Jul 13, 2026, 10:57 PM UTC

Last update: Jul 13, 2026, 11:17 PM UTC

Resolved: Jul 13, 2026, 11:17 PM UTC

Affected: tgg3fzt5nzzc

Canva AI's official report →

Updates

  • resolved

    This incident is now resolved. Thank you for your patience and understanding.

    Jul 13, 2026, 11:17 PM UTC

  • identified

    The issue has been identified: - Users are shown the wrong status of their subscription

    Jul 13, 2026, 11:04 PM UTC

  • investigating

    Some users may have issues using Canva. Our teams are urgently looking into this and we will provide an update soon.

    Jul 13, 2026, 10:57 PM UTC

← All outage history