Skip to main content

Grammarly · 60d ago

Login to Grammarly via superhuman.com may be temporarily unavailable

Resolved

Timeline

Started: Jul 16, 2026, 8:59 AM UTC

Last update: Jul 16, 2026, 1:16 PM UTC

Resolved: Jul 16, 2026, 1:12 PM UTC

Affected: b7kzcfwckrx2

Grammarly's official report →

Updates

  • resolved

    Amazon has resolved the CloudFront service outage, and our services are back to normal.

    Jul 16, 2026, 1:12 PM UTC

  • monitoring

    We introduced temporary changes to mitigate this issue during CloudFront's outage. Access to Grammarly via superhuman.com should now be restored. We are monitoring the results.

    Jul 16, 2026, 9:10 AM UTC

  • identified

    We have identified an issue affecting access to Grammarly services via superhuman.com. This may be related to a temporary Amazon CloudFront outage. We apologize for any inconvenience, and updates will be provided as they become available.

    Jul 16, 2026, 8:59 AM UTC

← All outage history