Grammarly · 130d ago
Some Grammarly and Superhuman users may be unable to log in
ResolvedYes — Grammarly had a problem on May 15, 2026, and Grammarly has since marked it resolved. Grammarly's latest word: “This incident has been resolved.”
Timeline
Started: May 15, 2026, 4:33 PM UTC
Last update: May 15, 2026, 4:45 PM UTC
Resolved: May 15, 2026, 4:45 PM UTC
Affected: b7kzcfwckrx2
Updates
resolved
This incident has been resolved.
May 15, 2026, 4:45 PM UTC
monitoring
A fix has been implemented and we are monitoring the results.
May 15, 2026, 4:43 PM UTC
investigating
We’re currently working through a service disruption that is preventing our users from logging in or resetting passwords. We apologize for any inconvenience, and updates will be provided as they become available.
May 15, 2026, 4:33 PM UTC
More Grammarly incidents
- Chat is not working at go.superhuman.com — resolved, 6h ago
- Users May Experience Login Issues Across Some Grammarly and Superhuman Products — resolved, 39d ago
- Go may work slowly or intermittently — resolved, 55d ago
- Login to Grammarly via superhuman.com may be temporarily unavailable — resolved, 68d ago
- PDF reports may not be available in the Grammarly Editor — resolved, 139d ago
- Generative AI features may not work as expected in Grammarly for Windows — resolved, 147d ago