ElevenLabs · 9d ago
Increase in latency in the Global Residency for Speech-to-Text and Dubbing requests
ResolvedTimeline
Started: Sep 4, 2026, 1:55 PM UTC
Last update: Sep 4, 2026, 9:01 PM UTC
Resolved: Sep 4, 2026, 9:01 PM UTC
Updates
resolved
After completing the monitoring stage, we have confirmed that STT latency has returned to baseline stability.
Sep 4, 2026, 9:01 PM UTC
monitoring
The issue has been fixed, the error rate should be zero. We are currently monitoring the situation.
Sep 4, 2026, 2:34 PM UTC
identified
We've identified the root cause and are rolling out a fix. Error rates should be improving, and we're continuing to monitor.
Sep 4, 2026, 2:16 PM UTC
investigating
We're investigating a latency increase on the Global Residency server for Speech-to-Text and Dubbing models, affecting a small subset of requests.
Sep 4, 2026, 1:55 PM UTC