Skip to main content

ElevenLabs · 10d ago

EU - STT - Increase in latency in the EU Residency for Speech-to-Text requests

Resolved

Timeline

Started: Sep 4, 2026, 11:41 AM UTC

Last update: Sep 4, 2026, 12:12 PM UTC

Resolved: Sep 4, 2026, 12:12 PM UTC

Updates

  • resolved

    The issue has been resolved, everything is back at normal.

    Sep 4, 2026, 12:12 PM UTC

  • monitoring

    We have released a fix, the error rate is back at zero. We are monitoring the situation.

    Sep 4, 2026, 12:07 PM UTC

  • investigating

    We're investigating a latency increase on the EU Residency server for Speech-to-Text models, affecting a small subset of requests.

    Sep 4, 2026, 11:41 AM UTC

← All outage history