Skip to main content

ElevenLabs · 2d ago

Batch calling degraded in EU residency

Resolved

Timeline

Started: Aug 27, 2026, 1:05 PM UTC

Last update: Aug 27, 2026, 1:08 PM UTC

Resolved: Aug 27, 2026, 1:08 PM UTC

Updates

  • resolved

    Latency has since decreased, and we are working on adding more alerts on our side to help us identify and respond to similar latency issues earlier.

    Aug 27, 2026, 1:08 PM UTC

  • identified

    Outbound Batch calls in the European residency experienced dispatch delays of up to 30 minutes between 08:00 and 11:00 UTC.

    Aug 27, 2026, 1:05 PM UTC

← All outage history