Skip to main content

Notion AI · 52d ago

Notion is down

Resolved

Timeline

Started: Jul 24, 2026, 11:24 AM UTC

Last update: Jul 24, 2026, 12:35 PM UTC

Resolved: Jul 24, 2026, 12:35 PM UTC

Updates

  • resolved

    It has been resolved and Notion is back to normal.

    Jul 24, 2026, 12:35 PM UTC

  • monitoring

    Our team is monitoring and investigating this

    Jul 24, 2026, 11:51 AM UTC

  • identified

    We have an outage issue and Notion is not loading

    Jul 24, 2026, 11:24 AM UTC

← All outage history