Skip to main content

Notion AI · 52d ago

Automation processing delays

Resolved

Timeline

Started: Jul 24, 2026, 7:20 AM UTC

Last update: Jul 24, 2026, 9:22 AM UTC

Resolved: Jul 24, 2026, 9:22 AM UTC

Updates

  • resolved

    This incident has now been resolved.

    Jul 24, 2026, 9:22 AM UTC

  • monitoring

    The issue has been mitigated. We're continuing to monitor the situation.

    Jul 24, 2026, 7:58 AM UTC

  • identified

    We're currently experiencing delays in automation processing. Automations may take longer than expected to complete, but they will continue processing.

    Jul 24, 2026, 7:20 AM UTC

← All outage history