Skip to main content

Notion AI · 54d ago

Unavailable or degraded user search performance

Resolved

Timeline

Started: Jul 21, 2026, 4:25 PM UTC

Last update: Jul 21, 2026, 7:57 PM UTC

Resolved: Jul 21, 2026, 7:57 PM UTC

Updates

  • resolved

    This incident is now resolved.

    Jul 21, 2026, 7:57 PM UTC

  • monitoring

    The degraded user search performance has resolved for 30+ minutes. Our teams are continuing to monitor and will provide ongoing updates as we work to fully resolve this issue.

    Jul 21, 2026, 5:28 PM UTC

  • investigating

    We're investigating an issue where some large workspaces are experiencing unavailable or degraded user search performance due to an issue within our edge cache.

    Jul 21, 2026, 4:25 PM UTC

← All outage history