Skip to main content

Notion AI · 60d ago

Core Notion product degraded

Resolved

Timeline

Started: Jul 16, 2026, 3:46 PM UTC

Last update: Jul 16, 2026, 4:18 PM UTC

Resolved: Jul 16, 2026, 4:18 PM UTC

Updates

  • resolved

    This incident is now resolved.

    Jul 16, 2026, 4:18 PM UTC

  • investigating

    The core Notion product is degraded. Some users may experience errors or degraded performance across Notion. We’re investigating and will share updates as we learn more.

    Jul 16, 2026, 3:46 PM UTC

← All outage history