Skip to main content

Notion AI · 65d ago

Degraded performance on the Calendar connection flows

Resolved

Timeline

Started: Jul 11, 2026, 12:49 AM UTC

Last update: Jul 11, 2026, 2:42 AM UTC

Resolved: Jul 11, 2026, 2:42 AM UTC

Updates

  • resolved

    The issue is now resolved.

    Jul 11, 2026, 2:42 AM UTC

  • identified

    We're working on a resolving an issue affecting Calendar connection flows.

    Jul 11, 2026, 12:49 AM UTC

← All outage history