Skip to main content

Notion AI · 82d ago

Degraded performance on Notion AI Enterprise Search

Resolved

Timeline

Started: Jun 24, 2026, 6:04 AM UTC

Last update: Jun 24, 2026, 1:53 PM UTC

Resolved: Jun 24, 2026, 1:53 PM UTC

Updates

  • resolved

    This issue has now been resolved

    Jun 24, 2026, 1:53 PM UTC

  • investigating

    We're currently investigating an issue with AI connector search results. Some users may experience a degraded performance on Notion AI Enterprise Search. Our engineering team is actively working on a fix. We will provide another update once this issue is resolved.

    Jun 24, 2026, 6:04 AM UTC

← All outage history