Skip to main content

Midjourney · 88d ago

Jobs are queuing

Resolved

Timeline

Started: Jun 18, 2026, 9:40 AM UTC

Last update: Jun 18, 2026, 11:09 AM UTC

Resolved: Jun 18, 2026, 11:09 AM UTC

Affected: wv96z2wj385j, qcwxbrn0kl8l, 06nk3dpb9phl, 484gh10ykyxd

Midjourney's official report →

Updates

  • resolved

    This incident has been resolved.

    Jun 18, 2026, 11:09 AM UTC

  • monitoring

    A fix has been implemented and we are monitoring the results.

    Jun 18, 2026, 10:37 AM UTC

  • identified

    The issue has been identified and a fix is being implemented.

    Jun 18, 2026, 9:40 AM UTC

← All outage history

Midjourney outage: Jobs are queuing (Jun 18, 2026) | AI Status