Lovable · 62d ago
Issue preventing users from setting up new custom email domains
ResolvedTimeline
Started: Jul 14, 2026, 9:28 AM UTC
Last update: Jul 14, 2026, 9:52 AM UTC
Resolved: Jul 14, 2026, 9:52 AM UTC
Updates
resolved
This incident has been resolved.
Jul 14, 2026, 9:52 AM UTC
investigating
We are aware of an issue that is preventing some users from setting up new custom email domains. Our team is investigating.
Jul 14, 2026, 9:28 AM UTC