GitHub Copilot · 5d ago
Disruption with Copilot Code Review
ResolvedTimeline
Started: Sep 4, 2026, 8:39 PM UTC
Last update: Sep 9, 2026, 5:07 PM UTC
Resolved: Sep 4, 2026, 10:26 PM UTC
Updates
resolved
On September 4, 2026, between 20:04 and 22:26 UTC, GitHub Copilot code review experienced an increased failure rate. Affected pull request reviews failed to complete or post review comments.<br /><br />The incident was caused by a change to the service’s authentication permissions that prevented it from submitting affected reviews to the GitHub API. We reverted the change and restored normal operation by 22:26 UTC.<br /><br />We apologize for the disruption.
Sep 4, 2026, 10:26 PM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Sep 4, 2026, 10:25 PM UTC
investigating
We are applying the mitigation and expect recovery within approximately 30 minutes.
Sep 4, 2026, 9:54 PM UTC
investigating
Some users may be experiencing failures when using Copilot code review. We have identified the root cause and are working on a mitigation.
Sep 4, 2026, 8:57 PM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Sep 4, 2026, 8:39 PM UTC