GitHub Copilot · 48d ago
Disruption with some GitHub services
ResolvedTimeline
Started: Jul 20, 2026, 12:25 AM UTC
Last update: Jul 28, 2026, 12:29 PM UTC
Resolved: Jul 20, 2026, 1:46 AM UTC
Updates
resolved
Between July 19, 2026, at 23:05 UTC and July 20, 2026, at 03:55 UTC, Actions self-hosted and larger runners were unable to connect to GitHub. During this period, Actions jobs were delayed or failed when trying to acquire a runner. Jobs using standard and Mac hosted runners were not affected. Reconnection traffic from affected runners also increased load on GitHub APIs, resulting in 3-4 seconds of additional average request latency and elevated 5xx error rates.<br /><br />The incident was caused by a certificate lifecycle management failure in a subset of internal services, resulting in an SSL certificate expiration that disrupted runner connectivity. We restored service by rotating the affected certificate. Recovery began at 02:45 UTC. By 03:55 UTC, queued workflow backlog had been processed and workflow delay rates returned to normal.<br /><br />To prevent recurrence, we are strengthening certificate renewal automation, adding fallback expiry monitoring and alerting, and improving circuit-breaker protections during runner API disruptions to reduce the risk of cascading impact to other APIs.
Jul 20, 2026, 1:46 AM UTC
investigating
Git LFS API success rates have returned to normal. We will continue to monitor the service closely.
Jul 20, 2026, 1:45 AM UTC
investigating
The Git LFS API issues have been identified as being related to a separate incident where Actions is experiencing degraded availability. We’re consolidating our investigation efforts under that incident.
Jul 20, 2026, 1:15 AM UTC
monitoring
Some Git LFS operations, and loading files through the API are failing. We are investigating.
Jul 20, 2026, 12:26 AM UTC
monitoring
Some Git LFS operations, and loading files through the API are failing. We are investigating.
Jul 20, 2026, 12:25 AM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Jul 20, 2026, 12:25 AM UTC