Skip to main content

GitHub Copilot · 4d ago

Disruption with Login and Release Asset downloads

Resolved

Timeline

Started: Aug 12, 2026, 9:39 PM UTC

Last update: Aug 25, 2026, 7:58 PM UTC

Resolved: Aug 12, 2026, 10:56 PM UTC

GitHub Copilot's official report →

Updates

  • resolved

    On August 12 and 13, 2026, some anonymous (logged-out) requests to github.com experienced HTTP 5xx errors when loading pages like the sign-in page, and when downloading release assets, due to an unusual traffic pattern that repeatedly overloaded a part of our infrastructure that serves these types of requests. There were three windows of impact: (1) August 12 from 16:34 to 18:34 UTC, with an average error rate of 16.16% that peaked at 28.6%; (2) August 12 from 19:00 to 22:56 UTC, with an average error rate of 16.55% that peaked at 24.18%; and (3) August 13 from 06:19 to 08:05 UTC, with an average error rate of 2.01% that peaked at 7.49%.<br />Requests from signed-in users were unaffected.<br /><br />We mitigated the incidents by applying traffic controls at our network edge that limited any requests matching the pattern identified previously, thereby preventing overload on our systems.<br /><br />Since these incidents occurred, we have tightened our monitoring systems to alert server-side errors that affect logged-out traffic. We are also working to further strengthen our edge protections and reduce the time to detect and mitigate similar incidents.

    Aug 12, 2026, 10:56 PM UTC

  • investigating

    We have identified the root cause and are working on mitigation. Errors on the login page and downloading release assets have decreased, but we are not fully mitigated. We will continue to provide updates.

    Aug 12, 2026, 10:22 PM UTC

  • investigating

    We are investigating issues with Login and when downloading Release Assets. We will continue to keep users updated on progress towards mitigation.

    Aug 12, 2026, 9:43 PM UTC

  • investigating

    We are investigating reports of impacted performance for some GitHub services.

    Aug 12, 2026, 9:39 PM UTC

← All outage history