GitHub Copilot · 2h ago
Actions Larger Runner Jobs for some customers may be slow to start
ResolvedYes — GitHub Copilot had a problem on September 14, 2026, and GitHub Copilot has since marked it resolved. GitHub Copilot's latest word: “This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.”
Timeline
Started: Sep 14, 2026, 6:40 PM UTC
Last update: Sep 14, 2026, 7:35 PM UTC
Resolved: Sep 14, 2026, 7:35 PM UTC
Updates
resolved
This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 14, 2026, 7:35 PM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Sep 14, 2026, 7:01 PM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Sep 14, 2026, 6:40 PM UTC
More GitHub Copilot incidents
- Incident with several GitHub Services — resolved, 2d ago
- Delays in commit processing — resolved, 13d ago
- Incident with Grok Copilot AI Model Provider — resolved, 11d ago
- Disruption with Copilot Code Review — resolved, 10d ago
- Degradation in repos contents API — resolved, 10d ago
- Elevated rate of errors for OpenAI models provided by Copilot — resolved, 15d ago