Skip to main content

GitHub Copilot · 16h ago

Incident with Actions and Pull Requests

Resolved

Timeline

Started: Aug 26, 2026, 10:56 PM UTC

Last update: Aug 28, 2026, 10:10 PM UTC

Resolved: Aug 27, 2026, 12:26 AM UTC

Affected: hhtssxt0f5v2, br0l2tvcx85d

GitHub Copilot's official report →

Updates

  • resolved

    On August 26, 2026, from 21:55 UTC to 23:58 UTC, 2.6% of workflow runs triggered by pull request events were delayed, with the impact rising as high as 25% at its peak. Some users also experienced delays in pull request merge-commit generation, mergeability information, and merge-button availability. Actions and Pull Requests fully recovered by 23:58 UTC; the incident was resolved at 00:26 UTC after normal operation was confirmed. <br /><br />Background jobs that process pull request updates and generate merge commits were impacted by timeouts reaching a single partition of git data. This resulted in a backlog in pull request merge-commit processing, delaying pull request-triggered GitHub Actions workflows and some mergeability information. <br /><br />We reduced workload, shifted traffic away from affected infrastructure, and restored the affected service component to a healthy state. Together, these actions helped drain the backlog and restore normal operations. <br /><br />We are working to improve resource saturation detection and to eliminate customer impact in this scenario by isolating impact, placing better bounds on retries, and strengthening backpressure to make our systems more resilient under load.

    Aug 27, 2026, 12:26 AM UTC

  • monitoring

    The degradation affecting Actions and Pull Requests has been mitigated. We are monitoring to ensure stability.

    Aug 27, 2026, 12:26 AM UTC

  • investigating

    We confirmed full recovery beginning at 23:58 UTC. Actions workflow runs and pull request merges are operating normally. We will now resolve the incident while continuing to monitor service health.

    Aug 27, 2026, 12:25 AM UTC

  • investigating

    We've applied mitigations and are seeing recovery in Actions workflow runs and blocked pull request merges. We're continuing to monitor for sustained health of merge commit creates before resolving.

    Aug 27, 2026, 12:01 AM UTC

  • investigating

    We are investigating elevated delays and timeouts affecting Actions workflow runs triggered by pull request events. 20% of actions runs have delayed starts of more than 5 minutes and up to 4% of runs failed to trigger. We are actively working on mitigation and will provide updates as we learn more.

    Aug 26, 2026, 10:57 PM UTC

  • investigating

    We are investigating reports of degraded performance for Actions and Pull Requests

    Aug 26, 2026, 10:56 PM UTC

← All outage history