GitHub Copilot · 6h ago
Incident with Pull Requests
ResolvedYes — GitHub Copilot had a problem on September 20, 2026, and GitHub Copilot has since marked it resolved. GitHub Copilot's latest word: “This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.”
Timeline
Started: Sep 20, 2026, 10:13 PM UTC
Last update: Sep 20, 2026, 11:22 PM UTC
Resolved: Sep 20, 2026, 11:22 PM UTC
Affected: hhtssxt0f5v2
Updates
resolved
This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 20, 2026, 11:22 PM UTC
monitoring
A git fileserver issue caused a brief delay in creating some merge commits - we've isolated the underlying server and already observed recovery.
Sep 20, 2026, 10:32 PM UTC
monitoring
The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.
Sep 20, 2026, 10:27 PM UTC
investigating
We are investigating reports of degraded performance for Pull Requests
Sep 20, 2026, 10:13 PM UTC
More GitHub Copilot incidents
- Actions Larger Runner Jobs for some customers may be slow to start — resolved, 6d ago
- Elevated rate of errors for OpenAI models provided by Copilot — resolved, 3d ago
- Disruption with some GitHub services — resolved, 5d ago
- Degradation with Gemini 3.8 Flash — resolved, 5d ago
- Degradation in repos contents API — resolved, 16d ago
- Incident with several GitHub Services — resolved, 8d ago