GitHub Copilot · 55d ago
Disruption with some GitHub services
ResolvedTimeline
Started: Jul 16, 2026, 9:13 AM UTC
Last update: Jul 21, 2026, 9:50 AM UTC
Resolved: Jul 16, 2026, 12:20 PM UTC
Updates
resolved
On July 16, 2026, between 08:50 UTC and 09:50 UTC, the GitHub MCP Server’s web_search tool experienced elevated failures. The average error rate was 42% and peaked at 82% of requests to the tool. Other GitHub MCP Server tools were unaffected. This was caused by degradation at a downstream web search provider.<br /><br />The incident was mitigated when the downstream provider recovered, after which we confirmed that the tool’s success rate had returned to normal.<br /><br />We are improving the tool’s resilience and failure handling to reduce the customer impact and duration of similar incidents.
Jul 16, 2026, 12:20 PM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Jul 16, 2026, 10:17 AM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Jul 16, 2026, 9:30 AM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Jul 16, 2026, 9:13 AM UTC