GitHub Copilot · 4h ago
Disruption with some GitHub services
ResolvedYes — GitHub Copilot had a problem on September 15, 2026, and GitHub Copilot has since marked it resolved. GitHub Copilot's latest word: “This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.”
Timeline
Started: Sep 15, 2026, 7:11 PM UTC
Last update: Sep 15, 2026, 8:00 PM UTC
Resolved: Sep 15, 2026, 8:00 PM UTC
Updates
resolved
This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 15, 2026, 8:00 PM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Sep 15, 2026, 7:48 PM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Sep 15, 2026, 7:11 PM UTC
More GitHub Copilot incidents
- Degradation in repos contents API — resolved, 11d ago
- Incident with several GitHub Services — resolved, 3d ago
- Disruption with some GitHub services — resolved, 14h ago
- Actions Larger Runner Jobs for some customers may be slow to start — resolved, 1d ago
- Delays in commit processing — resolved, 14d ago
- Incident with Grok Copilot AI Model Provider — resolved, 12d ago