GitHub Copilot · 49m ago
Disruption with billing information updates
ResolvedYes — GitHub Copilot had a problem on September 24, 2026, and GitHub Copilot has since marked it resolved. GitHub Copilot's latest word: “This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.”
Timeline
Started: Sep 24, 2026, 4:51 PM UTC
Last update: Sep 24, 2026, 8:41 PM UTC
Resolved: Sep 24, 2026, 8:41 PM UTC
Updates
resolved
This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Sep 24, 2026, 8:41 PM UTC
monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Sep 24, 2026, 8:24 PM UTC
investigating
We have applied the mitigation and are seeing signs of recovery. We are continuing to monitor the system closely.
Sep 24, 2026, 8:10 PM UTC
investigating
We are continuing to work on mitigation. We will post another update in approximately one hour.
Sep 24, 2026, 6:22 PM UTC
investigating
We have identified the problem and are actively working on mitigation.
Sep 24, 2026, 5:40 PM UTC
investigating
We are investigating failures on billing information updates. Customers may be unable to create or update their billing information in the meantime.
Sep 24, 2026, 4:51 PM UTC
investigating
We are investigating reports of impacted performance for some GitHub services.
Sep 24, 2026, 4:51 PM UTC
More GitHub Copilot incidents
- Incident with Pull Requests — resolved, 4d ago
- Incident across several services — resolved, 1d ago
- Disruption with some GitHub services — resolved, 10d ago
- Degradation with Gemini 3.8 Flash — resolved, 9d ago
- Actions Larger Runner Jobs for some customers may be slow to start — resolved, 10d ago
- Elevated rate of errors for OpenAI models provided by Copilot — resolved, 7d ago