Skip to main content

ElevenLabs · 59d ago

Conversation History Not Showing Recent Calls (EU Residency) - All Conversation are appearing with a delay

Resolved

Timeline

Started: Jul 17, 2026, 8:37 AM UTC

Last update: Jul 17, 2026, 9:22 AM UTC

Resolved: Jul 17, 2026, 9:22 AM UTC

Updates

  • resolved

    The issue has been resolved. All the previous conversations should be visible now.

    Jul 17, 2026, 9:22 AM UTC

  • monitoring

    We have fixed the issue, all the conversations should become visible. We are monitoring the situation.

    Jul 17, 2026, 9:05 AM UTC

  • investigating

    Conversations in the EU Residency are appearing in Conversation History with a smaller delay. However, nothing is lost; all the conversations are saved. We are working on a fix.

    Jul 17, 2026, 8:37 AM UTC

← All outage history