Skip to main content

ElevenLabs · 89d ago

Issues with logging in to the website for certain users

Resolved

Timeline

Started: Jun 17, 2026, 2:08 PM UTC

Last update: Jun 17, 2026, 2:28 PM UTC

Resolved: Jun 17, 2026, 2:27 PM UTC

Updates

  • resolved

    The issue has been resolved, the users can now login normally.

    Jun 17, 2026, 2:27 PM UTC

  • investigating

    We are currently investigating an issue where certain users are unable to log in to the website.

    Jun 17, 2026, 2:08 PM UTC

← All outage history