Skip to main content

Cursor · 13d ago

Investigating service degradation

Resolved

Timeline

Started: Sep 1, 2026, 1:01 AM UTC

Last update: Sep 1, 2026, 1:14 AM UTC

Resolved: Sep 1, 2026, 1:14 AM UTC

Affected: k0trcq273dr6, vsny1qv7v86c, mwv1g9sc7kdh, rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Sep 1, 2026, 1:14 AM UTC

  • investigating

    We are investigating degraded performance for requests that use Composer 2.5. Users may see failed or retried requests in Automations, Cloud Agents, the CLI, and the IDE when Composer 2.5 is used. Other models are unaffected.

    Sep 1, 2026, 1:01 AM UTC

← All outage history