Skip to main content

Cursor · 2d ago

Investigating service degradation — cursor.com and IDE

Resolved

Timeline

Started: Aug 27, 2026, 7:31 PM UTC

Last update: Aug 27, 2026, 7:38 PM UTC

Resolved: Aug 27, 2026, 7:38 PM UTC

Affected: jh0714rgjgt4, rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved. Sign-in to Cursor has returned to normal operation.

    Aug 27, 2026, 7:38 PM UTC

  • monitoring

    A fix has been implemented and we are monitoring for service restoration.

    Aug 27, 2026, 7:35 PM UTC

  • investigating

    We are investigating a service degradation affecting sign-in to Cursor.

    Aug 27, 2026, 7:31 PM UTC

← All outage history