Cursor · 48d ago
Investigating Elevated Cursor Grok 4.5 Errors
ResolvedTimeline
Started: Jul 28, 2026, 12:34 AM UTC
Last update: Jul 28, 2026, 12:45 AM UTC
Resolved: Jul 28, 2026, 12:45 AM UTC
Affected: rflc60xp5jp2
Updates
resolved
This incident has been resolved.
Jul 28, 2026, 12:45 AM UTC
investigating
We are investigating a service degradation affecting IDE & Cursor Grok 4.5
Jul 28, 2026, 12:34 AM UTC