Skip to main content

Cursor · 26d ago

Increased error rates for Composer 2.5

Resolved

Timeline

Started: Aug 19, 2026, 12:52 PM UTC

Last update: Aug 19, 2026, 3:54 PM UTC

Resolved: Aug 19, 2026, 3:54 PM UTC

Affected: k0trcq273dr6, vsny1qv7v86c, mwv1g9sc7kdh, jh0714rgjgt4, rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Aug 19, 2026, 3:54 PM UTC

  • monitoring

    A fix has been implemented and we are monitoring for service restoration.

    Aug 19, 2026, 2:26 PM UTC

  • identified

    The root cause has been identified and a fix is being implemented.

    Aug 19, 2026, 2:20 PM UTC

  • investigating

    We are investigating a service degradation affecting Composer 2.5 (non-fast). Users may experience errors when making requests using this model.

    Aug 19, 2026, 12:52 PM UTC

← All outage history