Cursor · 4h ago
Sign-in and dashboard errors for some users
ResolvedYes — Cursor had a problem on September 18, 2026, and Cursor has since marked it resolved. Cursor's latest word: “This incident has been resolved.”
Timeline
Started: Sep 18, 2026, 11:02 PM UTC
Last update: Sep 18, 2026, 11:13 PM UTC
Resolved: Sep 18, 2026, 11:13 PM UTC
Affected: jh0714rgjgt4
Updates
resolved
This incident has been resolved.
Sep 18, 2026, 11:13 PM UTC
monitoring
Sign-in is recovering. The issue came from our authentication provider, who has identified the cause and is seeing recovery on their side. We are monitoring to confirm everything is back to normal.
Sep 18, 2026, 11:07 PM UTC
investigating
We are investigating an issue affecting sign-in. Signing in, signing out, and loading the dashboard may hang or fail. If you are already signed in, your session should continue to work normally. We will provide another update shortly.
Sep 18, 2026, 11:02 PM UTC
More Cursor incidents
- Investigating service degradation — Grok Bot — resolved, 10h ago
- Investigating service degradation — Grok Bot — resolved, 16h ago
- Investigating service degradation — Cloud Agents and Automations — resolved, 2d ago
- Investigating service degradation — Grok Bot — resolved, 2d ago
- Investigating service degradation — Grok Bot — resolved, 3d ago
- Investigating service degradation — resolved, 3d ago