Cursor · 3h ago
Investigating service degradation
ResolvedYes — Cursor had a problem on September 16, 2026, and Cursor has since marked it resolved. Cursor's latest word: “This incident has been resolved.”
Timeline
Started: Sep 16, 2026, 8:03 AM UTC
Last update: Sep 16, 2026, 8:42 AM UTC
Resolved: Sep 16, 2026, 8:42 AM UTC
Affected: vsny1qv7v86c, rflc60xp5jp2
Updates
resolved
This incident has been resolved.
Sep 16, 2026, 8:42 AM UTC
monitoring
A fix has been implemented. We are monitoring recovery and will provide another update once the incident is fully resolved.
Sep 16, 2026, 8:09 AM UTC
investigating
We are investigating elevated error rates affecting xAI models in the Cursor IDE and CLI. Some Agent requests may fail.
Sep 16, 2026, 8:03 AM UTC
More Cursor incidents
- Investigating service degradation — resolved, 14h ago
- Investigating Grok service degradation — resolved, 2d ago
- Investigating service degradation — resolved, 5d ago
- Investigating service degradation — Review Agents and Cloud Agents — resolved, 6d ago
- Grok Bot computers unreachable for some users — resolved, 9d ago
- Investigating service degradation — CLI, Cloud Agents, and IDE — resolved, 9d ago