Cursor · 48d ago
Investigating service degradation — cursor.com, Automations, and Cloud Agents
ResolvedTimeline
Started: Jul 28, 2026, 6:19 PM UTC
Last update: Jul 28, 2026, 6:24 PM UTC
Resolved: Jul 28, 2026, 6:24 PM UTC
Affected: k0trcq273dr6, mwv1g9sc7kdh, jh0714rgjgt4
Updates
resolved
This incident has been resolved.
Jul 28, 2026, 6:24 PM UTC
monitoring
A fix has been implemented and we are monitoring for service restoration.
Jul 28, 2026, 6:21 PM UTC
investigating
We are investigating a service degradation affecting cursor.com, Automations, and Cloud Agents.
Jul 28, 2026, 6:19 PM UTC