Skip to main content

Cursor · 68d ago

Incorrect Usage Amount on Dashboard

Resolved

Timeline

Started: Jul 8, 2026, 2:28 PM UTC

Last update: Jul 8, 2026, 2:58 PM UTC

Resolved: Jul 8, 2026, 2:58 PM UTC

Affected: jh0714rgjgt4

Cursor's official report →

Updates

  • resolved

    This incident has been resolved. Usage should display correctly in the dashboard.

    Jul 8, 2026, 2:58 PM UTC

  • investigating

    We are investigating a service degradation affecting cursor.com, causing usage to incorrectly display as 0%

    Jul 8, 2026, 2:28 PM UTC

← All outage history