Skip to main content

Cursor · 12d ago

Investigating service degradation

Resolved

Timeline

Started: Sep 2, 2026, 12:48 AM UTC

Last update: Sep 2, 2026, 4:07 AM UTC

Resolved: Sep 2, 2026, 3:07 AM UTC

Affected: k0trcq273dr6, vsny1qv7v86c, mwv1g9sc7kdh, rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Sep 2, 2026, 4:07 AM UTC

  • monitoring

    A fix has been implemented and we are monitoring for service restoration.

    Sep 2, 2026, 1:04 AM UTC

  • investigating

    We're currently investigating degraded performance affecting requests made with Composer 2.5 and Grok 4.6 Fast. While these models are in use, you may encounter failed or retried requests across Automations, Cloud Agents, the CLI, and the IDE. Other models are unaffected.

    Sep 2, 2026, 12:48 AM UTC

← All outage history