Cursor · 1h ago
Investigating service degradation — Cloud Agents and Automations
OngoingYes — Cursor is having a problem right now. Cursor currently reports this incident as investigating. Cursor's latest word: “We are continuing to investigate this issue.”
Timeline
Started: Sep 17, 2026, 3:20 PM UTC
Last update: Sep 17, 2026, 3:58 PM UTC
Affected: k0trcq273dr6, mwv1g9sc7kdh
Updates
investigating
We are continuing to investigate this issue.
Sep 17, 2026, 3:58 PM UTC
investigating
We are currently investigating this issue. We will provide updates as more information becomes available.
Sep 17, 2026, 3:50 PM UTC
investigating
We are investigating a service degradation affecting Cloud Agents and Automations
Sep 17, 2026, 3:20 PM UTC
More Cursor incidents
- Investigating service degradation — Grok Bot — resolved, 5h ago
- Investigating service degradation — Grok Bot — resolved, 1d ago
- Investigating service degradation — resolved, 1d ago
- Investigating service degradation — resolved, 2d ago
- Investigating Grok service degradation — resolved, 3d ago
- Investigating service degradation — resolved, 6d ago