Cursor · 44d ago
Investigating service degradation
ResolvedTimeline
Started: Jul 31, 2026, 7:50 PM UTC
Last update: Jul 31, 2026, 9:10 PM UTC
Resolved: Jul 31, 2026, 9:10 PM UTC
Affected: k0trcq273dr6, 2x2chyqwmkzl, vsny1qv7v86c, mwv1g9sc7kdh, jh0714rgjgt4, rflc60xp5jp2
Updates
resolved
This incident has been resolved. All services have returned to normal operation.
Jul 31, 2026, 9:10 PM UTC
monitoring
Service is largely recovering. Some intermittent issues may remain as we finish restoring all systems. We are continuing to monitor.
Jul 31, 2026, 8:56 PM UTC
monitoring
A fix has been implemented and we are monitoring for service restoration.
Jul 31, 2026, 8:37 PM UTC
identified
We have identified the issue causing widespread failures across Cursor and are working on a fix. Users may continue to see errors in the IDE, Cloud Agents, Automations, and related services until the fix is fully rolled out.
Jul 31, 2026, 8:34 PM UTC
investigating
We are continuing to investigate a widespread issue affecting Cursor. Users may still see failures across the IDE, Cloud Agents, Automations, and related services. We will post another update shortly.
Jul 31, 2026, 8:21 PM UTC
investigating
We are investigating a widespread issue affecting Cursor. Users may see failures across the IDE, Cloud Agents, Automations, and related services.
Jul 31, 2026, 7:50 PM UTC