Skip to main content

Cursor · 61d ago

Investigating service degradation

Resolved

Timeline

Started: Jul 14, 2026, 7:52 PM UTC

Last update: Jul 15, 2026, 9:11 AM UTC

Resolved: Jul 15, 2026, 9:11 AM UTC

Affected: rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Jul 15, 2026, 9:11 AM UTC

  • investigating

    We are investigating a service degradation. Some users may experience occasional low rate errors when using grok 4.5 models.

    Jul 14, 2026, 7:52 PM UTC

← All outage history