Cursor · 63d ago
Investigating service degradation
ResolvedTimeline
Started: Jul 13, 2026, 7:41 AM UTC
Last update: Jul 13, 2026, 7:58 AM UTC
Resolved: Jul 13, 2026, 7:58 AM UTC
Affected: k0trcq273dr6, 2x2chyqwmkzl, vsny1qv7v86c, mwv1g9sc7kdh, jh0714rgjgt4, rflc60xp5jp2
Updates
resolved
This incident has been resolved.
Jul 13, 2026, 7:58 AM UTC
investigating
We are investigating a service degradation. Affected agent surfaces: Composer, Grok
Jul 13, 2026, 7:41 AM UTC