Skip to main content

Cursor · 38d ago

MCP authentication failures in Automations and Cloud Agents

Resolved

Timeline

Started: Aug 7, 2026, 3:53 PM UTC

Last update: Aug 7, 2026, 6:50 PM UTC

Resolved: Aug 7, 2026, 6:50 PM UTC

Affected: k0trcq273dr6, mwv1g9sc7kdh

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Aug 7, 2026, 6:50 PM UTC

  • identified

    The root cause has been identified and a fix is being implemented.

    Aug 7, 2026, 4:04 PM UTC

  • investigating

    We are investigating an issue where users are unable to authenticate with MCP servers in Automations and Cloud Agents. Affected runs may fail to connect to their MCP tools.

    Aug 7, 2026, 3:53 PM UTC

← All outage history