Cursor · 27d ago
Investigating service degradation
ResolvedTimeline
Started: Aug 18, 2026, 10:38 AM UTC
Last update: Aug 18, 2026, 11:45 AM UTC
Resolved: Aug 18, 2026, 11:45 AM UTC
Affected: jh0714rgjgt4
Updates
resolved
This incident has been resolved.
Aug 18, 2026, 11:45 AM UTC
monitoring
A fix has been implemented and we are monitoring for service restoration.
Aug 18, 2026, 11:02 AM UTC
investigating
We are investigating an issue preventing users from removing members from teams.
Aug 18, 2026, 10:38 AM UTC