Skip to main content

Cursor · 4h ago

Investigating service degradation

Resolved

Yes — Cursor had a problem on September 21, 2026, and Cursor has since marked it resolved. Cursor's latest word: “This incident has been resolved.”

See Cursor's live status →

Timeline

Started: Sep 21, 2026, 6:39 AM UTC

Last update: Sep 21, 2026, 7:00 AM UTC

Resolved: Sep 21, 2026, 7:00 AM UTC

Affected: k0trcq273dr6, vsny1qv7v86c, mwv1g9sc7kdh, rflc60xp5jp2

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Sep 21, 2026, 7:00 AM UTC

  • investigating

    We are investigating degraded performance for requests that use Grok 4.6. Users may see failed or retried requests in Automations, Cloud Agents, the CLI, and the IDE when Grok 4.6 is used. Other models are unaffected.

    Sep 21, 2026, 6:39 AM UTC

More Cursor incidents

Is Cursor down right now?All outage history →