Skip to main content

Cursor · 4d ago

Investigating service degradation — Review Agents and Cloud Agents

Resolved

Timeline

Started: Sep 10, 2026, 5:07 PM UTC

Last update: Sep 10, 2026, 5:32 PM UTC

Resolved: Sep 10, 2026, 5:32 PM UTC

Affected: 2x2chyqwmkzl, mwv1g9sc7kdh

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Sep 10, 2026, 5:32 PM UTC

  • investigating

    We are investigating a service degradation affecting Review Agents and Cloud Agents. Cloud Agents using "Privacy Mode" may experience errors and start delays. For Review Agents, Security Agents and PR Approval agents are impacted.

    Sep 10, 2026, 5:07 PM UTC

← All outage history