Skip to main content

Cursor · 48d ago

Investigating service degradation — Cloud Agents

Resolved

Timeline

Started: Jul 27, 2026, 5:09 PM UTC

Last update: Jul 27, 2026, 7:39 PM UTC

Resolved: Jul 27, 2026, 7:39 PM UTC

Affected: mwv1g9sc7kdh

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Jul 27, 2026, 7:39 PM UTC

  • monitoring

    Automations are back to normal, and cloud agent start failures have subsided. We're monitoring closely to confirm full recovery.

    Jul 27, 2026, 6:46 PM UTC

  • identified

    Some Cursor Automations may fail to start, and running Automations may be unable to post replies in Slack or open pull requests. We've identified the causes and fixes are rolling out.

    Jul 27, 2026, 5:41 PM UTC

  • investigating

    We are investigating a service degradation affecting Cloud Agents.

    Jul 27, 2026, 5:09 PM UTC

← All outage history