Skip to main content

Cursor · 59d ago

Investigating service degradation — Cloud Agents

Resolved

Timeline

Started: Jul 16, 2026, 10:33 PM UTC

Last update: Jul 17, 2026, 12:15 AM UTC

Resolved: Jul 17, 2026, 12:15 AM UTC

Affected: mwv1g9sc7kdh

Cursor's official report →

Updates

  • resolved

    This incident has been resolved.

    Jul 17, 2026, 12:15 AM UTC

  • investigating

    We are continuing to investigate this issue. Cloud Agents may fail to run properly because of an upstream Github incident: https://www.githubstatus.com/incidents/gxycch3076xk

    Jul 16, 2026, 10:54 PM UTC

  • investigating

    We are investigating a service degradation affecting Cloud Agents.

    Jul 16, 2026, 10:33 PM UTC

← All outage history