Skip to main content

Canva AI · 82d ago

Some users may have issues accessing Canva

Resolved

Timeline

Started: Jun 23, 2026, 11:01 PM UTC

Last update: Jun 23, 2026, 11:51 PM UTC

Resolved: Jun 23, 2026, 11:51 PM UTC

Canva AI's official report →

Updates

  • resolved

    This incident is now resolved. Thank you for your patience and understanding.

    Jun 23, 2026, 11:51 PM UTC

  • identified

    We have identified the issue. Some customers may encounter a "Page Not Found" error when using Canva. Our team is actively investigating and working on a resolution.

    Jun 23, 2026, 11:19 PM UTC

  • investigating

    Some users may have issues accessing Canva. Our teams are urgently looking into this and we will provide an update soon.

    Jun 23, 2026, 11:01 PM UTC

← All outage history