anthropic
Billing and subscription management issues
Status: resolved | Severity: degraded
Cite this incidentTimeline
Started: 2026-05-28T19:04:04.082Z
Updated: 2026-05-28T19:23:57.832Z
Resolved: 2026-05-28T19:23:57.798Z
Impact scope
Impacted regions: None reported
Impacted models: None reported
Impacted components: None reported
Official sources
Provider: anthropic
View official incident pageUpdates
resolved
The issue affecting Claude services has been resolved. Impact occurred from 18:27 UTC to 19:05 UTC.
2026-05-28T19:23:57.798Z
monitoring
A fix has been deployed for the issue affecting Claude services and we are monitoring for recovery.
2026-05-28T19:17:35.695Z
identified
We are currently experiencing issues with billing and subscription management on claude.ai and the Anthropic Console. Users may see errors when viewing subscription details, payment methods, or attempting to upgrade or change plans. Chat and API access are not affected. We have identified the cause and are working on a fix.
2026-05-28T19:04:04.206Z